Chinese Brake Rotors - Page 3 - SV1000 Portal
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
post #31 of 31 (permalink) Old 9th July 2013, 09:51 AM
L-Plate Rider
 
Join Date: Dec 2012
 ♂ New Zealand
Posts: 4
Brakes Help

kind of related,

I have an 07SV1000N. The left front rotor popped because the caliper wasnt returning one of the pistons fully, putting pressure on the rotor. So I bought wavey after markets, cleaned out the calipers, replaced the pads and fitted the rotors. ISSUE - the bike now feels like the pads are grabbing at low speeds and there is a grinding noise (like really worn pads) although there is plenty of meat left.
Is it possible that the Rotors are not uniform in thickness?

my apologies if this has been answered elswhere.
CharlieSV is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the SV1000 Portal forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome