SV1000 Portal - View Single Post - Your Power Commander Experience
View Single Post
post #8 of (permalink) Old 6th June 2013, 02:08 AM
schmidt314
KNEE DRAGGER
 
schmidt314's Avatar
 
Join Date: Nov 2005
 ♂ United States
Portland Oregon
Posts: 4,835
Garage
Over the years I probably have installed 40 or 50 PCIIIs for all of our race bikes, F1 Sidescars and several of my street bikes.

Have I have problems? Yes, we actually had a year or two period where we had several boxes completely fail and it was a pain in the ass to say the least. Besides this they have been pretty much trouble free even the ones with the wire taps and not the full harness type connectors.

We did have a major issue with one bike, but we think it might been caused by RF interference from the spark plug high tension lead being so close to the PCIII harness. I was never quite sure, but reroute and unplug and replug everything seemed to fix it.

-MS


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
schmidt314 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome