Odd fast blinker issue - SV1000 Portal
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 9 (permalink) Old 26th June 2019, 12:14 AM Thread Starter
Fair weather rider
 
Madson26's Avatar
 
Join Date: May 2012
 ♂ United States
Posts: 94
Odd fast blinker issue

Hello again. I've been out awhile, it's been a long couple of years between a divorce and a move 1/4 of the way across the country, but Im back and ready to put more miles on the SV1K. I couldn't stand the factory signals so they came off years ago. I had some LED fronts (with resistors) and rears as well (with resistors to fix the fast blink. My riding group had a hard time seeing the rears in the daytime since they were clear lenses so I swapped them out for some standard bulbs and removed the resistors. They served me well for years but I lost a lense and I need to replace. I like the look of the factory rears from my Kawasaki Z125 but when I wired it up it blinks fast. They are not LED, why are they doing that? Another thing that has me stumped is if I put on the 4 ways, they all blink normal. Do I need resistors? A flasher relay? If someone could please explain this to me I would appreciate it.
Thanks
Madson26 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 26th June 2019, 01:01 AM
Scooter boy
 
spiderman's Avatar
 
Join Date: Sep 2003
 ♂ New Zealand
Posts: 48
Garage
Are the bulbs the same wattage?
spiderman is offline  
post #3 of 9 (permalink) Old 26th June 2019, 01:38 AM
Bike curious
 
oldbaldsob's Avatar
 
Join Date: May 2005
 ♂ United States
Springfield, MOFO
Posts: 8,445
Garage
FWIW, I bought the flasher relay below on eBay for my '05 rebuild since I used LEDs for my front and rear signals (it will still work with non LED bulbs too). It was dirt cheap so I figured I'd take the chance. It took forever to get to me too. But with that price, you can't go wrong!

https://www.ebay.com/itm/Suzuki-SV65...kAAOSwaQ9dCwMI

LEDrelay.jpg


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
oldbaldsob is offline  
 
post #4 of 9 (permalink) Old 26th June 2019, 02:19 AM
Hardcore Biker
 
Missing Link's Avatar
 
Join Date: Dec 2017
 ♂ Australia
Queensland, Orstraylya
Posts: 434
Garage
Quote:
Originally Posted by oldbaldsob View Post
FWIW, I bought the flasher relay below on eBay for my '05 rebuild since I used LEDs for my front and rear signals (it will still work with non LED bulbs too). It was dirt cheap so I figured I'd take the chance. It took forever to get to me too. But with that price, you can't go wrong!

https://www.ebay.com/itm/Suzuki-SV65...kAAOSwaQ9dCwMI

Attachment 115461
Thats the same as what i got.... works really well with LED's and was cheap as chips.....

I might no' be a smart man Jenny....but i can pain' ma copper colored bike a dif'ren color.....
.
.
2003 Copper SV1000S
Repainted Ford PE (Petroleum Mica)
Yoshi 2:1 collectors and Arrow titanium can...
One owner..... 285,000kms and counting...
Missing Link is offline  
post #5 of 9 (permalink) Old 26th June 2019, 02:36 AM Thread Starter
Fair weather rider
 
Madson26's Avatar
 
Join Date: May 2012
 ♂ United States
Posts: 94
I have no idea if they are the same wattage. I'd seriously doubt it since they are 14 years newer. That's the only thing I can think of is that newer regular bulbs don't draw the same power. I'll snag one and see. Thanks for the replies!
Madson26 is offline  
post #6 of 9 (permalink) Old 29th June 2019, 05:44 AM Thread Starter
Fair weather rider
 
Madson26's Avatar
 
Join Date: May 2012
 ♂ United States
Posts: 94
Thanks fellas, the LED flasher relay did the trick. I think they look pretty good, especially since they came out of my spare parts bin for free. Just shortened stock z125 blinkers
Attached Images
File Type: jpg 15617870743424277093863660858229_1561787089186.jpg (250.2 KB, 7 views)
Madson26 is offline  
post #7 of 9 (permalink) Old 29th June 2019, 05:46 AM Thread Starter
Fair weather rider
 
Madson26's Avatar
 
Join Date: May 2012
 ♂ United States
Posts: 94
Normal speed and factory bright/dot legal
Attached Images
File Type: jpg 15617871080276097067677478211434_1561787147526.jpg (277.7 KB, 8 views)
Madson26 is offline  
post #8 of 9 (permalink) Old 29th June 2019, 05:49 AM Thread Starter
Fair weather rider
 
Madson26's Avatar
 
Join Date: May 2012
 ♂ United States
Posts: 94
I found probably the same relay, but only a few hundred miles from me. $9.99 + shipping and I got it in 2 days. Worth the extra money since I want to ride tomorrow
Madson26 is offline  
post #9 of 9 (permalink) Old Today, 12:37 AM
Hardcore Biker
 
Missing Link's Avatar
 
Join Date: Dec 2017
 ♂ Australia
Queensland, Orstraylya
Posts: 434
Garage
Nobody will miss you with those thats for sure.... good size for visibility....

I might no' be a smart man Jenny....but i can pain' ma copper colored bike a dif'ren color.....
.
.
2003 Copper SV1000S
Repainted Ford PE (Petroleum Mica)
Yoshi 2:1 collectors and Arrow titanium can...
One owner..... 285,000kms and counting...
Missing Link is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the SV1000 Portal forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome