High beam pass switch stopped working - SV1000 Portal
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 2 (permalink) Old 4th February 2020, 02:29 PM Thread Starter
L-Plate Rider
 
Paul.H's Avatar
 
Join Date: Oct 2019
Posts: 3
High beam pass switch stopped working

I noticed rececntly my high beam pass switch has stopped working,
The switch mechanism looks fine in the switch gear,
Any ideas welcome ?
Paul.H is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 5th February 2020, 01:37 AM
Hardcore Biker
 
Missing Link's Avatar
 
Join Date: Dec 2017
 ♂ Australia
Queensland, Orstraylya
Posts: 762
Garage
I had that happen once......pretty certain all i did was pull the switchblock apart and
wash out the swithces with brake clean/electrical contact cleaner, blow it dry and then WD-40.....

One owner..... 298,500kms and counting... 1.5k to go....

2003 Copper SV1000S
Repainted Ford PE (Petroleum Mica)
Yoshi 2:1 collectors and Arrow titanium can...
Missing Link is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the SV1000 Portal forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome