SV1000 Portal - Search Results
Advanced Search
Showing results 1 to 5 of 5
Search took 0.00 seconds.
Search: Posts Made By: Speedjunkie444
Forum: SV1000 discussion   31st July 2019, 06:06 PM
Replies: 13
Views: 969
Posted By Speedjunkie444
I know this is an old thread but I have to try....

I know this is an old thread but I have to try. So this sounds a bit like what I am dealing with, I was searching around the shifter and didn't see an allen key. Can you maybe identify it on a photo?
Forum: SV1000 discussion   31st July 2019, 05:41 PM
Replies: 18
Views: 705
Posted By Speedjunkie444
Tranny Problems

Transmission experts. I am having an issue with shifting into third gear, when initially attempting to shift its as if the shifter won't move up at all, I release and try again it will then engage...
Forum: SV1000 discussion   31st July 2019, 05:37 PM
Replies: 5
Views: 340
Posted By Speedjunkie444
I have no idea bout the bulbs, they seem to be...

I have no idea bout the bulbs, they seem to be the same as factory as they are the same color and brightness as stock. The white connectors are notorious for burning up under heavy amperage...
Forum: SV1000 discussion   30th June 2019, 07:47 PM
Replies: 5
Views: 340
Posted By Speedjunkie444
Found it!!!

Found it!!!
Forum: SV1000 discussion   30th June 2019, 07:13 PM
Replies: 5
Views: 340
Posted By Speedjunkie444
So I have searched everywhere and haven't had...

So I have searched everywhere and haven't had much luck.

So the other day after riding about 30 miles, I parked the bike for about an hour. I went back out started it and all of my light...
Showing results 1 to 5 of 5

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome