SV Portal Forums banner
electrical
1-5 of 5 Results
  1. SV1000 discussion
    I have another threat somewhere but I can not find it. Where I am at right now the FI light is on and it will no longer even attempt to crank all that happens when I push the starter button is a click at the relay. I tried to bypass everything and put cables straight to the starter motor...
  2. SV1000 discussion
    So, every time I want to start my bike up, I have to get on it and violently shake the entire thing from left to right with the clutch lever in and start button fully engaged. I have never once lost power during riding. This issue only exists when I start the bike (or attempt to). When something...
  3. Tweaking, Tuning & Tricking
    Hey all. My speedometer gauge cluster stopped working recently. My bike has somewhere around 95,000 miles on her. Right now the speedometer led area is not working at all. No blinking lights just a blank screen. Also the tachometer doesnt work at all, None of the backlights work, The only lights...
  4. Bike Zone
    Hit the link for more info. Looks like the SV1000 is NOT on the list. http://www.autoblog.com/2011/02/28/suzuki-recalls-73k-motorcycles-over-electrical-issue/ Chris
  5. SV1000 discussion
    I just bought a 2003 SV1000S thats in great shape and rode great for two days no problems. Now when I went to start it today to go ride I turn the key to on and nothing happens at all, no dash lights, no taillight, nothing. I have tested the battery and charged it and it is good. I have checked...
1-5 of 5 Results
Top