SV Portal Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Good Afternoon All.
I have an issue with my bike at approximately 3500rpm where I appear to have what appears to be a flat spot when I ride on a constant throttle. It is bordering on what I can only describe as almost a misfire if that makes any sense. It feels like the throttle has slipped through my hand briefly.
I have checked and trimmed my HT leads, replaced the plugs but no change. I am pretty handy with spanners but Fuel Injection is a very murky area for me and I would rather not start fiddling and make things worse without good advice. I have also been told by a mate who was following me once that the bike is over fuelling as well so I do not know if there is a link between the two. The bike is standard except for a pair of CCC cans. Any advice will be greatly received
 

·
Disturbed, very...
2003 SV1000S
Joined
·
1,948 Posts
Possibly fouled injectors....or the fuel pump filter is clogged. I had an issue years ago where the bike was tripping over itself around those revs but revved through not too bad...
Being followed, people said their eyes were stinging from unburnt fuel.... Lining in tank had stripped out, clogged the filter, and the injectors pissed rather than sprayed....
Got that sorted and whoa nellie, off she went....
 
  • Like
Reactions: Urbanjugle

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Possibly fouled injectors....or the fuel pump filter is clogged. I had an issue years ago where the bike was tripping over itself around those revs but revved through not too bad...
Being followed, people said their eyes were stinging from unburnt fuel.... Lining in tank had stripped out, clogged the filter, and the injectors pissed rather than sprayed....
Got that sorted and whoa nellie, off she went....
Thank you Mr Link - I will give that a look- you have described perfectly what I am getting.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Well this is what I found -There is also a rubber cushion that sits on top of the filter which is now the consistency of an oxo cube. I have a two week wait for a replacement so its gone back in for now as it is my daily ride. I have already noticed a massive change in the running of the bike now - its not 100% but its not far off but no more flat spot. Its much smoother low down now as well and that was an issue I was not even aware of !!. My bike has only done about 15'000 miles and I think that is probably part of the problem. I've only had it 2 years and looking back over the MoT records there have been instances where the bike has only done a few hundred miles over a 2 year period. Anyhow thanks for pointing me in the right direction, most appreciated
Glove Ingredient Cuisine Rectangle Food
 

·
Disturbed, very...
2003 SV1000S
Joined
·
1,948 Posts
Hooly dooly, never seen a pick up screen fall apart like that, makes me wonder what the filter is like..... IF you get the chance....the plastic body the pump is plugged into is the actual fuel filter, shake out the fuel that is in it into a clean container, observe contents, then clean the container and dump the filter in it over night with a very strong fuel system cleaner solution.
So, 1 can of fuel cleaner to 2 parts fuel...... and shake the filter regularly...... drain it out, and see what crap comes out....you are looking to get the flow to comeback out where the pump plugs in, as that will be the dirty side.
 
  • Like
Reactions: Urbanjugle

·
Registered
Joined
·
210 Posts
wow , that filter just desintegrated! glad you caught it...your fuel pump is gonna need some good cleaning as ML said and i wouldnt forget injectors too! they most likley gonna be dirty...since there i would check inside of your fuel tank, fuel line, quick connectors..overflow hoses..shes 03 - 19 yo things get old and brittle like us:p
i just finished installing my refreshed fuel pump an 1hr ago! i could lately hear sqeeky loud noise comming from my fuel tank when i turned ign. key on.... bike was also getting bit sluggish on acceleration..
lucky i had spare fuel pump assy which i cleaned up, replaced new fuel pressure regulator and done the external fuel filter mod/ bypass internal filter...took it for spin around the block felt nice and smooth.
keep us posted how it goes...
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Hooly dooly, never seen a pick up screen fall apart like that, makes me wonder what the filter is like..... IF you get the chance....the plastic body the pump is plugged into is the actual fuel filter, shake out the fuel that is in it into a clean container, observe contents, then clean the container and dump the filter in it over night with a very strong fuel system cleaner solution.
So, 1 can of fuel cleaner to 2 parts fuel...... and shake the filter regularly...... drain it out, and see what crap comes out....you are looking to get the flow to comeback out where the pump plugs in, as that will be the dirty side.
Thank you - I will do that when the "rubber cushion" arrives.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
wow , that filter just desintegrated! glad you caught it...your fuel pump is gonna need some good cleaning as ML said and i wouldnt forget injectors too! they most likley gonna be dirty...since there i would check inside of your fuel tank, fuel line, quick connectors..overflow hoses..shes 03 - 19 yo things get old and brittle like us:p
i just finished installing my refreshed fuel pump an 1hr ago! i could lately hear sqeeky loud noise comming from my fuel tank when i turned ign. key on.... bike was also getting bit sluggish on acceleration..
lucky i had spare fuel pump assy which i cleaned up, replaced new fuel pressure regulator and done the external fuel filter mod/ bypass internal filter...took it for spin around the block felt nice and smooth.
keep us posted how it goes...
i will - thanks for the advice
 
1 - 8 of 8 Posts
Top