SV Portal Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Good morning all,

Think this is the right thread to ask around, but if not, feel free to move it to the right section :)

I already used the search function quite a lot to find out more about the bike, which helped me so far, but know my project is getting to an end i may be dealing with some issues which i did not read about.

The project on itself :

Adding the M.Unit Blue to the bike

Reasons :
i already spent quite some on 3 ignition barrels (yes, i wore them out :yes:) so i decided i wanted to get rid of it and install keyless go.

apart from some automobile solutions i came acros the m.unit which i thought was pretty neat. So i got myself one, bought a second hand wiring loom and started to alter the loom.

now nearing the end of the installation, i was wondering i anybody else already tried installing one, and can give me some pointers on where to look at or what to watch out for.

I already read something about that 100ohms resistor, so i got that one implemented, but i have no clue on what the ECU is responding to if it does not "see" the sidestand, or the killswitch for example or how the not being present neutral signal in combination with the side stand will effect the starter system

For now i am still using the stock switches on the handle bars, but i am going at a later stage for pushbutton switches like and using the m.switch (thought that was the right name) and m.buttons.

So if anyone has any tips and tricks about fiddling with the starting system, please let me know! Once installed i will try and get a full upload of the project with pictures, just in case someone else wants to have a go at it.
 

·
KNEE DRAGGER
Joined
·
5,113 Posts
Good morning all,

Think this is the right thread to ask around, but if not, feel free to move it to the right section :)

I already used the search function quite a lot to find out more about the bike, which helped me so far, but know my project is getting to an end i may be dealing with some issues which i did not read about.

The project on itself :

Adding the M.Unit Blue to the bike

Reasons :
i already spent quite some on 3 ignition barrels (yes, i wore them out :yes:) so i decided i wanted to get rid of it and install keyless go.

apart from some automobile solutions i came acros the m.unit which i thought was pretty neat. So i got myself one, bought a second hand wiring loom and started to alter the loom.

now nearing the end of the installation, i was wondering i anybody else already tried installing one, and can give me some pointers on where to look at or what to watch out for.

I already read something about that 100ohms resistor, so i got that one implemented, but i have no clue on what the ECU is responding to if it does not "see" the sidestand, or the killswitch for example or how the not being present neutral signal in combination with the side stand will effect the starter system

For now i am still using the stock switches on the handle bars, but i am going at a later stage for pushbutton switches like and using the m.switch (thought that was the right name) and m.buttons.

So if anyone has any tips and tricks about fiddling with the starting system, please let me know! Once installed i will try and get a full upload of the project with pictures, just in case someone else wants to have a go at it.


I have installed MUnits and Mbutton set ups before. Not on an SV though.

Neutral, side stand, on/off, and clutch switch are all interlocked to the starter. I guess I don’t know what you are trying do. The 100Ω resistor is for a small comparator circuit one the ECU. Without it, bike will spin over, but not start because it will not spark or fire injectors.

Are you just wanting to get rid of the interlocks? It might be easier with an MUnit to just build a whole new circuit for starting, but remember, the interlocks are there for a reason to begin with.

-ms
 

·
Disturbed, very...
2003 SV1000S
Joined
·
1,272 Posts
I cant offer any help on this wiring issue, but, i am curious...you say you have worn out 3 ignition barrels ? I assume you mean the key lock portion.
Are you lubricating it with anything ? If so, maybe whatever you are using is damaging the barrel...

I only say this, as i see in your hello post that you have only put 40k km on the bike since you got it.... (85k in total)....
Seems strange, as i am still using the same barrel form new, and i have over 310K kms on mine.....
 

·
KNEE DRAGGER
Joined
·
5,113 Posts
I cant offer any help on this wiring issue, but, i am curious...you say you have worn out 3 ignition barrels ? I assume you mean the key lock portion.

Are you lubricating it with anything ? If so, maybe whatever you are using is damaging the barrel...



I only say this, as i see in your hello post that you have only put 40k km on the bike since you got it.... (85k in total)....

Seems strange, as i am still using the same barrel form new, and i have over 315K kms on mine.....

I was thinking the same thing.

I am on the original with my bike also with nearly 160,000 miles on mine. It is wearing now though. I can wiggle key out when in the on position. I have never attached anything to the key. Just a bare key.

-ms
 

·
Disturbed, very...
2003 SV1000S
Joined
·
1,272 Posts
I was thinking the same thing.

I am on the original with my bike also with nearly 160,000 miles on mine. It is wearing now though. I can wiggle key out when in the on position. I have never attached anything to the key. Just a bare key.

-ms
I have swapped over to my spare key, as the original one was optional (... as in, once it was on, you could take it out...ha ha)
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
I cant offer any help on this wiring issue, but, i am curious...you say you have worn out 3 ignition barrels ? I assume you mean the key lock portion.
Are you lubricating it with anything ? If so, maybe whatever you are using is damaging the barrel...

I only say this, as i see in your hello post that you have only put 40k km on the bike since you got it.... (85k in total)....
Seems strange, as i am still using the same barrel form new, and i have over 310K kms on mine.....
how much km???? 310k???? wow! that is a LOT!!!

i only do 16km one way 5 days a week - so that is 10 cycles at least in one week.

to be completely honest, the barrel that came with the bike felt wonky from the start. so i got a second hand replacement. after that also had difficulties getting the bike from steer lock to the on position i decided then to get a brand new one which has started to get rough already after 9 months - initialy greasing worked but couple of weeks ago i hardly could get if from lock position to on.

As i was already looking to replace the barrel, things just moved a little faster since then :)
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
the only thing i can imagine that is working agains my old barrel is that i got a ABM steer mod kit fitted which limits the steering lock angle that may cause extra tension to the mechanism, although i do not have to force the lock to work.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Anyway:

After a full saturday and a whole lot more hours before and after work i got it working.

lights and stuff where the easy part. Where it became fishy was when i turned on the ignition and the fuel pump did not ran. also the dial read CHEC so something wasnt working properly. Reading the wiring diagram it turned out that the orange/white wire that runs from the kill switch wasn't ground as i thought it was but it needed 12v after ignition. Then the unit runs like a charm.

still work in progress though as i am not really satisfied on how i put wiring inside the rear end mostly, so that needs some TLC. Also what i noticed is that, after adding a wire to the signal wire of the speed sensor is that my own speed reading isn't what i used to be with speeds up to 160km/h just doing 90 or 100km/h. I am guessing that i should have used a twisted wire, but maybe i need to check if i got it on the right wire.

one of the future projects is to add the m.button or other ones that look nice.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
I have installed MUnits and Mbutton set ups before. Not on an SV though.

Neutral, side stand, on/off, and clutch switch are all interlocked to the starter. I guess I don’t know what you are trying do. The 100Ω resistor is for a small comparator circuit one the ECU. Without it, bike will spin over, but not start because it will not spark or fire injectors.

Are you just wanting to get rid of the interlocks? It might be easier with an MUnit to just build a whole new circuit for starting, but remember, the interlocks are there for a reason to begin with.

-ms
most interlocks werent that hard to bypass. the only thing that is that my bike will be hard to start for somebody who does not know what i did to the bike.

So yes, i built my own starter system using excisting wiring. the safety of using the clutch lever is still in work as it felt good to have the lever being pulled when cranking.

i had to be creative though. hopefully i will be able to put all the works i did inside a small manual just for the sake of it but :whocares:
 

·
Disturbed, very...
2003 SV1000S
Joined
·
1,272 Posts
Congrats on getting it working...i would have taken it out and jumped all over it, then waffle stomped it down a drain.... (i hate electricals...)

I have removed my ignition/lock assembly a couple of times over the years and washed them out thoroughly with contact or brake cleaner and then lubed them back up again....

Not even the electrical component is sealed from the weather stupidly enough.....and it gets grotty....
 

·
Registered
Joined
·
118 Posts
also im just wonder what kind of ignition barrels did you use? was it OEM or not? because there are out there some knock off ignition barrels and those dont last, cause all sorts of probs in a short time after insalation....
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
i brought it to the bigger repair shop nearby, i can only assume he fitted a OEM replacement as i trust him to do so at that rate :D
 
1 - 12 of 12 Posts
Top