SV Portal Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi I’d just like to thank you for accepting me.Ive just bought a 1000S in blue.It’s a 03 plate and it’s been dry stored for a couple of years.Just seeing if battery will charge before I buy a new one.If it does want a new one has anyone got any recommendation.All the best for now.
 

·
Obsessed with SV1000s
Joined
·
8,734 Posts
Hi I’d just like to thank you for accepting me.Ive just bought a 1000S in blue.It’s a 03 plate and it’s been dry stored for a couple of years.Just seeing if battery will charge before I buy a new one.If it does want a new one has anyone got any recommendation.All the best for now.
Welcome! Check the tank for old gas with ethanol residue/rust. If you see any, pull the fuel pump out and clean the tank thoroughly. And while the fuel pump is out, it would be a good idea to take it apart and clean everything well. Lots of good YouTube vids on how to do this and clean the tank of rust. When you get the bike running, check for charging with a voltmeter. Dropping values may indicate a problem with your stator, in which case you may have damaged/destroyed flywheel magnets (an all too common problem most of us have experienced). Couple of good threads on this site about this issue and how to fix it. Let us know how she runs and post up pics!;)
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Welcome! Check the tank for old gas with ethanol residue/rust. If you see any, pull the fuel pump out and clean the tank thoroughly. And while the fuel pump is out, it would be a good idea to take it apart and clean everything well. Lots of good YouTube vids on how to do this and clean the tank of rust. When you get the bike running, check for charging with a voltmeter. Dropping values may indicate a problem with your stator, in which case you may have damaged/destroyed flywheel magnets (an all too common problem most of us have experienced). Couple of good threads on this site about this issue and how to fix it. Let us know how she runs and post up pics!;)
Thanks for the reply I’ll check that.Had battery on charge but not accepting charge so I’ll get a new battery for it.
 

·
Registered
Joined
·
2,210 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
Bought a new battery and fitted it.Put key in,pressed starte,engine turned over twice and fired up.Ran on choke for a short while then settled down to a nice even tick over.Not bad to say it hadn’t been started for 2 years
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
Took bike for a mot today.Sailed through no probs.Took back wheel out going to get it powder coated and a new tyre fitted.
 

·
Disturbed, very...
2003 SV1000S
Joined
·
1,419 Posts
Looks like you are off and running.....
 
1 - 9 of 9 Posts
Top